Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Forum: General SR20

Main Forum Discussion

+ Post New Thread
Forum: General SR20
- Main Forum Discussion
Threads: 4,027-4,048 of 7,009
Title / Thread Starter
Last Post By
Need help with A/C Compressor swap
Started by Isfahan, 2010-07-20 22:37
Replies: 5
Views: 2,263
2010-07-20 22:37
ECU code : P0000
Started by Wayne, 2010-07-20 07:11 1 2
Replies: 14
Views: 2,831
2010-07-20 07:11
drive belt(s) issue/Tolerance
Started by VEHMX95_B14, 2010-07-20 03:57
Replies: 3
Views: 1,223
2010-07-20 03:57
AC Compressor seized?
Started by JAY ROB, 2010-07-20 02:08
Replies: 8
Views: 3,288
2010-07-20 02:08
Replies: 3
Views: 1,686
2010-07-20 01:09
Replies: 16
Views: 4,719
2010-07-19 23:19
Third gear issues...
Started by nismo94tuner, 2010-07-19 07:16
Replies: 6
Views: 1,094
2010-07-19 07:16
A/C blows on high??
Started by Wayne, 2010-07-19 00:58
Replies: 3
Views: 1,026
2010-07-19 00:58
Overheating: Need quick advice
Started by Nismo_sr20, 2010-07-19 00:48 1 2
Replies: 12
Views: 2,002
2010-07-19 00:48
Bogging
Started by fubar1o2, 2010-07-18 16:25
Replies: 3
Views: 1,079
2010-07-18 16:25
Replacing a speed sensor?
Started by nismosr20, 2010-07-18 02:42
Replies: 9
Views: 2,821
2010-07-18 02:42
Im stuck, i can use some advice
Started by magoo_lc1, 2010-07-17 23:26
Replies: 6
Views: 1,451
2010-07-17 23:26
Replies: 5
Views: 1,290
2010-07-17 18:03
Replies: 19
Views: 6,110
2010-07-17 07:18
Curved vs straight fan blades
Started by David SE-R, 2010-07-16 23:40
Replies: 8
Views: 3,725
2010-07-16 23:40
Stock '93 NX2000 overheating
Started by JAY ROB, 2010-07-16 23:39 1 2
Replies: 10
Views: 1,810
2010-07-16 23:39
Clutch Cable Length?
Started by LikeTheMovies, 2010-07-16 05:07 1 2
Replies: 10
Views: 2,617
2010-07-16 05:07
Replies: 14
Views: 2,614
2010-07-16 00:56
Replies: 2
Views: 775
2010-07-15 17:02
Underdash plugs
Started by TheRealNighthog, 2010-07-15 07:44
Replies: 1
Views: 866
2010-07-15 07:44
low mile b14 in AZ
Started by blackwater32, 2010-07-14 23:53
Replies: 6
Views: 1,664
Ben
2010-07-14 23:53
Running problems
Started by Itswagner, 2010-07-14 22:36
Replies: 1
Views: 912
2010-07-14 22:36
Icon Legend and Forum Information
Contains unread posts
Contains no unread posts
Thread is closed
You have posted in this thread
Users Browsing this Forum
There are currently ? users browsing this forum. (? members & ? guests)
StubUserName

Back to top