Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Forum: General SR20

Main Forum Discussion

+ Post New Thread
Forum: General SR20
- Main Forum Discussion
Threads: 3,697-3,718 of 7,018
Title / Thread Starter
Last Post By
Replies: 0
Views: 845
2010-10-26 19:48
Other SR20 transmission options
Started by Kleensleeper, 2010-10-26 01:14
Replies: 6
Views: 2,528
2010-10-26 01:14
g20 axles vs SER axles
Started by Thomasf36, 2010-10-25 23:36 1 2
Replies: 13
Views: 3,333
2010-10-25 23:36
injector failure
Started by Tearoffguy, 2010-10-24 22:08
Replies: 4
Views: 1,625
2010-10-24 22:08
clutch identification
Started by BurtonNX2000, 2010-10-24 00:50
Replies: 2
Views: 1,318
2010-10-24 00:50
Jumper harness
Started by Topdog781, 2010-10-23 23:28
Replies: 4
Views: 1,633
2010-10-23 23:28
another exhaust thread
Started by djcslice, 2010-10-23 17:35 1 2 3
Replies: 20
Views: 4,127
2010-10-23 17:35
New member and new software.
Started by GaryS, 2010-10-23 07:54
Replies: 0
Views: 198
2010-10-23 07:54
Bj's Manifolds
Started by Daves_sr, 2010-10-22 13:02 1 2
Replies: 15
Views: 728
2010-10-22 13:02
B15 Tranny w/LSD For $400
Started by Zach92Ser, 2010-10-21 22:42
Replies: 8
Views: 2,393
2010-10-21 22:42
Zoom clutch???
Started by b14 mexicutioner, 2010-10-21 20:54
Replies: 8
Views: 2,920
2010-10-21 20:54
Grinding noise...need help.
Started by blackb15, 2010-10-21 17:43 1 2
Replies: 10
Views: 2,184
2010-10-21 17:43
Replies: 40
Views: 10,852
2010-10-21 08:15
Help Needed Asap: Axle Removal
Started by Thomasf36, 2010-10-21 03:31 1 2 3
Replies: 25
Views: 6,978
2010-10-21 03:31
5th gear issues...
Started by Jimithin7000, 2010-10-20 20:31
Replies: 9
Views: 2,925
2010-10-20 20:31
Replies: 0
Views: 764
2010-10-20 10:29
Replies: 1
Views: 1,175
2010-10-19 22:48
Decently priced CV boots?
Started by SENTRASER, 2010-10-19 18:31
Replies: 5
Views: 1,635
2010-10-19 18:31
Picked up another B14 sedan
Started by buffaloBill, 2010-10-19 01:07
Replies: 3
Views: 1,089
2010-10-19 01:07
wierd problem. can you help?
Started by kaotekxe, 2010-10-18 21:24
Replies: 2
Views: 849
2010-10-18 21:24
Installed motor....no spark?
Started by tomas527, 2010-10-18 21:19
Replies: 9
Views: 3,282
2010-10-18 21:19
Wiring Harness
Started by zephlar, 2010-10-18 04:47
Replies: 1
Views: 874
2010-10-18 04:47
Icon Legend and Forum Information
Contains unread posts
Contains no unread posts
Thread is closed
You have posted in this thread
Users Browsing this Forum
There are currently ? users browsing this forum. (? members & ? guests)
StubUserName

Back to top