Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Forum: General SR20

Main Forum Discussion

+ Post New Thread
Forum: General SR20
- Main Forum Discussion
Threads: 4,357-4,378 of 7,017
Title / Thread Starter
Last Post By
exhaust leak - weak motor mounts?
Started by vqman, 2010-04-11 20:45 1 2
Replies: 17
Views: 3,153
2010-04-11 20:45
New Paint Job Soon???
Started by sr20vet414, 2010-04-11 19:39 1 2 3
Replies: 24
Views: 5,062
2010-04-11 19:39
Coolant Temperature Sensor
Started by WingmanSR20, 2010-04-11 17:56 1 11 12 13
Replies: 124
Views: 46,328
2010-04-11 17:56
Replies: 7
Views: 4,843
2010-04-11 17:38
car dies at stops
Started by nissan-4-life, 2010-04-11 01:51 1 2
Replies: 12
Views: 2,367
2010-04-11 01:51
Jmr "truth Still Continues" $$$$
Started by sr20vet414, 2010-04-10 11:01
Replies: 9
Views: 2,081
2010-04-10 11:01
Power @40mph?
Started by 92SentraSE-R, 2010-04-10 06:14 1 2
Replies: 15
Views: 3,092
2010-04-10 06:14
LED cluster lights???
Started by jonwepa, 2010-04-10 01:21 1 2 3 4
Replies: 35
Views: 7,458
2010-04-10 01:21
Replies: 33
Views: 7,210
2010-04-10 01:18
Compression Test question
Started by Topdog781, 2010-04-09 21:47 1 2
Replies: 12
Views: 2,687
2010-04-09 21:47
Gearbox Possible Issue
Started by TheSam, 2010-04-09 15:16
Replies: 6
Views: 1,650
2010-04-09 15:16
No gap platiums?
Started by canx2k, 2010-04-09 03:08
Replies: 3
Views: 1,310
2010-04-09 03:08
Mystery coolant leak need help please
Started by 97 SR20, 2010-04-09 02:54 1 2 3
Replies: 27
Views: 7,842
2010-04-09 02:54
Axxtion STS
Started by fubar1o2, 2010-04-09 02:10
Replies: 4
Views: 1,636
2010-04-09 02:10
misfire/stumble/ high idle
Started by matt_pound, 2010-04-08 17:22 1 2
Replies: 15
Views: 5,525
2010-04-08 17:22
Need some help over here...
Started by jpsr20det, 2010-04-08 15:39
Replies: 1
Views: 1,052
2010-04-08 15:39
Replies: 0
Views: 1,205
2010-04-08 03:26
clutch almost new and it's slipping.?
Started by mrbass, 2010-04-07 19:16
Replies: 7
Views: 1,929
2010-04-07 19:16
sunroof help asap please...
Started by allmotor, 2010-04-07 16:02
Replies: 6
Views: 1,861
2010-04-07 16:02
Rpm not working
Started by cvkid15, 2010-04-07 12:43
Replies: 6
Views: 1,568
2010-04-07 12:43
Replies: 22
Views: 4,149
2010-04-07 12:39
Cheap shocks question?
Started by Mr SE-R, 2010-04-06 23:27
Replies: 6
Views: 2,112
2010-04-06 23:27
Icon Legend and Forum Information
Contains unread posts
Contains no unread posts
Thread is closed
You have posted in this thread
Users Browsing this Forum
There are currently ? users browsing this forum. (? members & ? guests)
StubUserName

Back to top