Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: Major Forum Changes Ahead

+ Reply To Thread
Posts: 251-260 of 284
2020-09-25 20:30:33
#251
I've noticed a small issue that cropped up as I was cleaning up the code.

When a post is liked, the "Like" button changes text, the total like count to the right of it goes up, and the list of members who like the post should be updated (without a page refresh).
That last part is not working properly anymore... Well, it works sometimes, but it's a bit flaky. So I'll try to figure out what's going on and sort that out ASAP.

Still, I'm very happy with this progress!
Last edited by BenFenner on 2020-09-26 at 12-40-13.
2020-09-26 11:53:30
#252
Update (Version 1.4.1)

The spotty behavior for the likes list (it didn't always update properly immediately after liking a post, and required a page refresh instead) has been fixed.
There can be a short delay, but now the likes list updates properly every time without a page refresh.

The last thing for this feature now is to get e-mails sending out for likes. Hopefully this won't get annoying. If it does, I can turn it off, and/or hurry up designing the ability to disable it on a per-user basis.
2020-09-26 12:52:31
#253
Update (Version 1.4.2)

E-mails now go out when a post is liked as well. This may be slightly annoying for some, but hopefully not too bad and hopefully it will be very useful for most everyone.
Eventually I can put in a control to allow users to disabled this.

I can't believe how fast the notifications drop-down menu and then likes capability came together.
I'd been dreading it for a long time, and with a clear/well-rested head it just all fell into place quite well.
I am quite happy with this, and now I expect the mentions feature to come along soon as well.

Example email:

Last edited by BenFenner on 2020-09-26 at 12-54-17.
2020-09-26 13:03:39
#254
During the recent work on likes, I changed it so the button to like/unlike a post now only shows up for users who are logged in. I forget exactly which update above that happened for, but I think it was the major 1.4.0 update.

Anyway, I knew I needed to test one more thing for users who are logged out, or who have fewer permissions than I do.

The links to view a member's liked posts in their member profile page should only show posts that the user has permission to see. I thought I got this right, but it seems that maybe no posts at all are showing for some visitors.
Right now if I visit one of these links (circled here) while logged out, I don't see any posts listed at all. I'll have to fix that before moving on to other things.

Can anyone else confirm they do, or do not see posts listed when visiting those links? If I don't get any feedback, I can test this myself. I just thought I'd ask.


Edit:

Update (Version 1.4.3)

I've fixed the issue mentioned above. It was affecting anyone who wasn't a Super Moderator/Administrator. Now everyone, including those logged out, can go to a member's profile page and visit the links to see that member's liked posts (still properly based on permissions). And actual posts will show now.

I imagine I'll work on getting mentions to work next.
Last edited by BenFenner on 2020-09-26 at 13-51-38.
2020-09-28 10:47:43
#255
Update (Version 1.4.4)

It was bugging me that notifications didn't go away immediately after visiting the corresponding page. The notification was deleted properly, and a page refresh would show that the notification was no longer active, but I really would prefer it to go away immediately, as expected.

So I worked on that this morning and now it behaves properly.

So for example, assume you get a PM, and a PM notification shows in the page header. In the past, visiting your PM inbox would clear the notification, but the header would still show 1 PM notification pending. Only after visiting a new page, or refreshing the current page, would that notification stop showing.
Now when you visit the PM inbox, the notification no longer shows without needing a page refresh.

I'm extremely happy with the way these notifications are working now. I don't think there are any more improvements to make in the general operation of how they work.
Last edited by BenFenner on 2020-09-28 at 10-49-40.
2020-10-13 11:19:06
#256
Originally Posted by SE-RMonkey
BTW, I'm unable to "like" your post, or any posts it seems.
What happens when you try to like a post?
Are you possibly blocking Javascript (hosted locally on the forum) somehow?

Maybe we can discuss in chat... I'll keep checking throughout the day.
Last edited by BenFenner on 2020-10-13 at 11-27-24.
2020-10-13 11:30:18
#257
Originally Posted by BenFenner
Originally Posted by SE-RMonkey
BTW, I'm unable to "like" your post, or any posts it seems.
What happens when you try to like a post?
Are you possibly blocking Javascript (hosted locally on the forum) somehow?


From my work desktop, nothing happens. From my phone, no problem. So, it must be this 10+ year old Vista machine I've been nursing along.
2020-10-13 12:53:23
#258
Oh, good to know that's probably the issue. What browser are you using on the old Vista machine? I may be able to test with, and solve that problem too.
2020-10-13 13:24:09
#259
Originally Posted by BenFenner
Oh, good to know that's probably the issue. What browser are you using on the old Vista machine? I may be able to test with, and solve that problem too.


Chrome.
2020-10-13 13:44:36
#260
Hmmm, that's really odd it wouldn't work on Chrome, even on an older OS like Vista. Unless they stopped updating Chrome for that OS...

I'll see what I can do. No promises though. Unless it's just not working on Chrome at all, for anyone... I'll obviously need to make sure that is working.

Does anyone else run Chrome that can confirm the "like" feature works, or does not work, with Chrome?
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top