Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 3,091-3,100 of 4,492
2014-04-24 01:17:52
#3091
let us know how they fit. even though I already bought and paid for mine id like to know
2014-04-24 01:52:37
#3092
oem fit, the clips are a little beefier than oem too which is a good thing. the back where the knob attaches to the lever is a little different design (sorry forgot to take pics, when I pull the panel to fix my front speakers I will take them then)

both look like the knob is the weak point, neither design has advantage over the other imo.

pics of installed.

rear doors (go ahead and laugh, im used to it)



front doors (continue laughing)

2014-04-24 03:27:33
#3093
finished my det swap from rusty 91 to immaculate 93 auto today, for the most part. runs, idles good and no leaks of any kind. the oil light flashes when I use right indicator though... so minor adjustments to make I guess as well as rear disk brakes from old rusty and get rid of those drums
2014-04-24 03:51:51
#3094
Originally Posted by zeneffect
oem fit, the clips are a little beefier than oem too which is a good thing. the back where the knob attaches to the lever is a little different design (sorry forgot to take pics, when I pull the panel to fix my front speakers I will take them then)

both look like the knob is the weak point, neither design has advantage over the other imo.

pics of installed.

rear doors (go ahead and laugh, im used to it)






Awesome!!!!!!!!!! I look forward to mine coming in a few days
2014-04-24 06:11:14
#3095
Ordered 2 for myself. I need c clips for mine
2014-04-24 11:39:09
#3096
Re: What Did You Do To Your B13 Today?
I was re painting my bars


Sent from my SPH-L600 using Tapatalk
2014-04-24 14:47:46
#3097
Used it to transport myself to work this morning.
2014-04-24 17:55:13
#3098
Originally Posted by Latino
Oh I thought you had the stock one laying about after you installed the B&M...


The stock one does not have a ball end although it still has to be 'manuvered' out of the linkage opening...
2014-04-25 00:06:19
#3099
Finally drove it with the new hood. I saw at least a 15 deg change in my coolant temps.

2014-04-25 00:14:04
#3100
Good news on the temp drop, Mike!
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top