Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 4,261-4,270 of 4,489
2016-09-14 10:28:20
#4261
Originally Posted by mercado
Your using the 20v head or the complete engine

Sent from my SM-N920P using Tapatalk

Sr20vet
2016-09-17 22:40:34
#4262
Finished up my new intake set up today some before and after pictures
2016-09-17 23:47:21
#4263
Put on 20v valve cover, changed oil, reverted back to stock intake manifold, inj4ctors, rail, damper, and fpr
2016-09-18 14:00:00
#4264
Great job

Sent from my SM-N920P using Tapatalk
2016-09-19 20:02:32
#4265
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX
2016-09-19 22:38:43
#4266
Originally Posted by hawaiiaNX
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX


boost without wideband? must be rich.
2016-09-20 01:51:20
#4267
Originally Posted by zeneffect
Originally Posted by hawaiiaNX
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX


boost without wideband? must be rich.


Yay you're letting all the precious boost scape , already metered air making the ecu add fuel but no o2 making it rich as hell prob 9's or worse , happened to me few times, careful not to full throttle/over taxed that turbo since its probably be overworking it never fully boosting from the air scaping, fried journal or seals might be the worse enemy
2016-09-20 19:33:07
#4268
Originally Posted by ztunedsr20
Originally Posted by zeneffect
Originally Posted by hawaiiaNX
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX


boost without wideband? must be rich.


Yay you're letting all the precious boost scape , already metered air making the ecu add fuel but no o2 making it rich as hell prob 9's or worse , happened to me few times, careful not to full throttle/over taxed that turbo since its probably be overworking it never fully boosting from the air scaping, fried journal or seals might be the worse enemy


Well, considering the leak was after the MAF but before the turbo (meaning it would be adding in unmetered air), wouldn't that make it run lean? Extra air going in but only as much fuel as the MAF was metering?

LMK what you guys think...

Branden
aka hawaiiaNX
2016-09-20 20:27:14
#4269
Originally Posted by hawaiiaNX
Originally Posted by ztunedsr20
Originally Posted by zeneffect
Originally Posted by hawaiiaNX
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX


boost without wideband? must be rich.


Yay you're letting all the precious boost scape , already metered air making the ecu add fuel but no o2 making it rich as hell prob 9's or worse , happened to me few times, careful not to full throttle/over taxed that turbo since its probably be overworking it never fully boosting from the air scaping, fried journal or seals might be the worse enemy


Well, considering the leak was after the MAF but before the turbo (meaning it would be adding in unmetered air), wouldn't that make it run lean? Extra air going in but only as much fuel as the MAF was metering?

LMK what you guys think...

Branden
aka hawaiiaNX


I meant rich, as in has a lot of money because running turbo without afr monitoring = dead motors
2016-09-20 22:09:57
#4270
Originally Posted by zeneffect
Originally Posted by hawaiiaNX
Originally Posted by ztunedsr20
Originally Posted by zeneffect
Originally Posted by hawaiiaNX
Swapped the following parts from my NX to my SE-R yesterday:

- GC Coil Sleeves w/ GC Camber Plates on KYB AGX struts (250F, 150R)
- ST Anti-Sway Bars
- OEM Front Brake Rotors and Pads
- Stock Shifter and ES Shifter Stabilizer
- Front Knuckles and LCA's w/ ES Bushings

Also, found that one of the caps on my intake pipe fell off so I was running SUPER lean and bogging really bad under boost. Now if I had a damned wideband installed, I would have known almost immediately. Rides better now, though have not had a chance to really push it in boost. Will report back later.

Branden
aka hawaiiaNX


boost without wideband? must be rich.


Yay you're letting all the precious boost scape , already metered air making the ecu add fuel but no o2 making it rich as hell prob 9's or worse , happened to me few times, careful not to full throttle/over taxed that turbo since its probably be overworking it never fully boosting from the air scaping, fried journal or seals might be the worse enemy


Well, considering the leak was after the MAF but before the turbo (meaning it would be adding in unmetered air), wouldn't that make it run lean? Extra air going in but only as much fuel as the MAF was metering?

LMK what you guys think...

Branden
aka hawaiiaNX


I meant rich, as in has a lot of money because running turbo without afr monitoring = dead motors


Ohhh. Hahaha! I gotcha. Well FWIW, car's been running for the last 4 years...though only at stock boost. Have made no efforts whatsoever to up the boost or make more power. Just needed it running. No dyno's around here as far as I know anyway.

Now once I pull the motor out to clean up and swap into the NX, you can be damned sure a wideband is going in with the new downpipe. Gonna need one for the Nismotronic SA anyway.

Branden
aka hawaiiaNX
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top