Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 4,071-4,080 of 4,489
2016-03-22 04:26:54
#4071
What Did You Do To Your B13 Today?
I started to get the parts for my 20v swap

Sent from my SM-N920P using Tapatalk
2016-03-22 06:03:03
#4072
washed her today she was covered in pollen.
Last edited by eggman on 2016-03-22 at 06-18-25.
2016-03-24 19:40:29
#4073
Missed it.
2016-03-26 17:58:15
#4074
Originally Posted by eggman
washed her today she was covered in pollen.
..


Ooooh thats purty.
2016-03-28 02:35:04
#4075
Happy Easter!

He is risen!

And by "He" I mean (primarily) my B13, Henry!

He's finally back together after having undergone a new level of surgery (for me, at least.) I took the intake manifold off in order to repair a leaky coolant hose under it, near the Oil Filter.

While I was there, I installed a thermal IM spacer, replaced the PCV (since lots of oil was pooling in the plenum,) deleted the EGR, replaced the FPR (since I thought the old was had broken (it hadn't,)) and reinstalled the cat (rather than the straight pipe) since I need to pass emissions.

So he's back on the road after having awoken from his hibernation/extended repair period.

Unfortunately the speedo stopped working halfway back home. Hopefully it just popped out of the cluster and doesn't need to be replaced.

In spite of that hiccup, I'm really enjoying being in the driver's seat of a B13 again, it's felt like forever!



Last edited by vorin on 2016-03-28 at 02-38-10.
2016-03-28 04:09:34
#4076
Welding up some holes that aren't needed

Sent from my SAMSUNG-SM-G920A using Tapatalk
2016-03-29 15:20:35
#4077
I drove it to work.

I couldn't get it exactly between two GT-Rs, but I came pretty close.



Unfortunately, some other issues are showing their face besides the speedo.

1. It will overheat when standing still.

I'll start with checking fuses and fan relays, hopefully today.

2. It's got a noisy vibration near the stereo at around 4k that's really annoying.

3. It's got a high idle since I removed the EGR. I already did the warm up TPS disconnect/reconnect, but it's staying at or above 1500rpm. Time to start with the idle adjust screw.
2016-03-29 18:03:03
#4078
Originally Posted by vorin
I drove it to work.

I couldn't get it exactly between two GT-Rs, but I came pretty close.



Unfortunately, some other issues are showing their face besides the speedo.

1. It will overheat when standing still.

I'll start with checking fuses and fan relays, hopefully today.

2. It's got a noisy vibration near the stereo at around 4k that's really annoying.

3. It's got a high idle since I removed the EGR. I already did the warm up TPS disconnect/reconnect, but it's staying at or above 1500rpm. Time to start with the idle adjust screw.


Check fans for overheating issues. Chances are fans or fan is dead which is common for B13s.

I have the same rattle behind radio at 4k RPMs. My old 91 SE-R did the same.

Check your vacuum lines related to EGR for high idle.
Last edited by NissanEgg on 2016-03-29 at 18-07-22.
2016-03-29 18:03:21
#4079
Cell phone post fail
Last edited by NissanEgg on 2016-03-29 at 18-06-00.
2016-03-29 18:50:59
#4080
The fans are new Mishimoto slim ones that I put in last year, so I don't think they're at fault.

I did my egr delete according to this thread - http://www.sr20-forum.com/general-maintenance/24765-egr-delete-information.html

And inside, it says that he had to adjust his idle down, so I'll do the same.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top