Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 4,031-4,040 of 4,489
2015-12-23 15:47:37
#4031
What Did You Do To Your B13 Today?
Took it to a jdm meet

Sent from my SM-N920P using Tapatalk
2015-12-25 02:01:16
#4032
2015-12-25 19:56:41
#4033
Car looks great mickey
2015-12-25 23:58:19
#4034
Originally Posted by nissansr20nx
Car looks great mickey


Thank you sir!

- - - Updated - - -

2015-12-26 01:16:13
#4035
Looking even better
2015-12-26 13:32:33
#4036
On the 24th, my Dad and I dug into the next project - fixing a water hose leak under the IM.

During our exploration, we found a thickly-oil-coated plenum and a surprising amount of oil in the runners.

We also found lots of otherwise-inaccessible hoses and pipes that I've ordered for replace, and decided to remove the EGR.

Album - https://goo.gl/photos/WrVs7qFkeesLKfMP7














2015-12-27 14:33:23
#4037
Dang good work Vorin! You have any spare b13 parts?
2016-01-02 03:37:37
#4038
Plenum and Runners are squeaky clean!

Anxiously awaiting for the orders for all of the replacement hoses that I'm replacing while the IM is off.




I don't have any spare parts to speak of.
Last edited by vorin on 2016-01-02 at 04-01-05.
2016-01-03 19:15:25
#4039
Tore down spare transmission, inspected, replaced 5th completely with hub, synchro, and gear. Reassembled and swapped onto the 4 door b13. No more 5th popout until 6 speed is on. I'll replace 5th on the new "spare" at a later date.
Last edited by zeneffect on 2016-01-03 at 19-22-03.
2016-01-11 14:48:43
#4040
Photo Album - https://goo.gl/photos/R5DSf4h3SozcCt6L7

I got the car back together with new water hoses under the IM, freshly-cleaned plenum and runners, thermal spacer between the head and runners, fabricated egr blockoff plates, new rubber hoses for PCV, TB coolant, IM coolant fuel inlet and return, and vacuum lines (but not heater hoses, still looking for those), cleaned up PCV, deleted EGR and BPT...

And it wouldn't start. The fuel filter and inlet were getting pressure, but the fuel return wasn't. After ordering a new FPR and installing it the problem remained. I had the intake and return lines switched.

So then it would start but idle high and strangely. I drove it around and the strangeness persisted. The idle might be steady (but rough) at 1k or hunting and searching all around and as high as 2.5k. Giving just a touch of throttle would cause it to rev way higher than it should, and giving it throttle and clutching out while it was already idling high would sometimes cause it to miss and the revs to nosedive.

I was thinking IAC/AAC or ECU troubles, when a wiser man suggested checking for IM air leaks, which we found at cyl 4.

I figure I'll need to loosen all of the IM bolts, including its brackets, then re-mount it and tighten it down starting at the head, then working my way to the plenum, then the plenum's gaskets as well as using the order here - [url]www.sr20-forum.com/general-sr20/24112-how-cleaning-intake-manifold.html[/url]















Last edited by vorin on 2016-01-11 at 15-19-55.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top