Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 2,821-2,830 of 4,489
2014-01-13 00:45:25
#2821
May sure it was still in the garage, then apologized to it for being pre-occupied with the "new" P10.
2014-01-18 00:36:32
#2822
scrapping/parting out my 91 rust bucket. charged battery to test sunroof assembly to sell to member, then realized I've misplaced the lone key...
2014-01-19 23:12:14
#2823

Installed a set of OEM foglights originally off of a 2000 Nissan Frontier
2014-01-20 02:23:56
#2824
Cleaned and painted my RS6 case
2014-01-20 03:05:38
#2825
Originally Posted by 91SE-Rdet
scrapping/parting out my 91 rust bucket. charged battery to test sunroof assembly to sell to member, then realized I've misplaced the lone key...


grab about 4 feet or misc wiring and jump the sunroof. last time i did this, i put the battery in my lap while sitting in the driver seat.
2014-01-20 14:10:54
#2826
Busted the SE-R loose this morning for a LONG run to work. First time she's been out in like 3 weeks so we "stretched her legs" a bit. Oh, and if the guy driving the Cavalier westbound on Rt 422 around 7:40am is reading this.... LOL!
2014-01-22 17:54:55
#2827
After months of installing N1 cams/ spring and retainers and swapping in my VE, I was all ready to start her up and go for a joy ride. All I needed was a quick axle shaft seal change and new MT-90. But of course I strip the fill plug. Now the tranny comes back out and my joy ride is delayed further!!!!!
2014-01-24 12:52:18
#2828
After about a week of 10*F here in NH...I put the charger on the battery this morning! Gonna get her juices flowing tonight but there ain't no juice to be had! :-/
2014-01-28 21:36:50
#2829
Starting working on a cooling plate for the b13. Had to make if fit different due to the front grill attaching different then stock. Not too bad for left over materials in my garage.

2014-01-31 14:08:57
#2830
Removed my disconnected autometer mechanical oil gauge from my custom dash tripod, moved my uego into the empty spot. Ordered the adapter from THE MAN @GregV to finally after 5 years, connect the oil line from the gauge to the motor. Will be mounting the gauge externally (prob on the hood). Anyone with experience doing this (pics help) will be appreciated. Thread started here in the b13 forum category.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top