Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 2,311-2,320 of 4,489
2013-02-08 05:29:59
#2311
Got an Alignment today.
2013-02-09 01:43:23
#2312
Originally Posted by zerogravity
Put on the Drag Radials and Took her to Irwindale Speedway to practice my launches. This was Thursday.





Today, I dug DEEP into Storage and found some goodies!


WS2 80mm Muffler, Sr16 Pistons and Rings, Full Gasket Set, Eagle Rods, JWT C3 Cams, and Brembo Rotors. Ill be busy this week!


I have a bnib WS2 80mm for sale on here $250 shipped if anyone likes yours and wants one of their own.
2013-02-09 02:38:33
#2313
Finally installed my 6 year old exhaust. It is still quiet until i hit VVL..HOLY COW!! 3" piping rules!
2013-02-09 05:26:38
#2314
started to replace some worn out wheel bearings but ran out of sunlight.



i removed the old bearing with a large hammer and a 1 1/4 to 1 1/2 adapter that a plumber would use, bought it from home depot



here you can see the bearing removed from the spindle


i was able to cut half-way thru the race and then cracked it, after it cracked i easily took it off




tomorrow i will re install the bearings and seals and be all done.
Last edited by artmor79 on 2013-02-09 at 05-33-12.
2013-02-09 14:17:33
#2315
had it primered
2013-02-09 17:36:57
#2316
Scraped the ice and snow off of it.
2013-02-09 18:57:03
#2317
Originally Posted by SE-RMonkey
Scraped the ice and snow off of it.


hahaha i didnt even get that far yet!

https://www.facebook.com/photo.php?fbid=2812333844587&l=60408e2e3e
2013-02-12 01:35:15
#2318
Went to Famoso raceway with a few Site members. It was good to be around fellow Sr20 powered peeps. Race my car and got a 14.8. I need better starts.





2013-02-17 20:23:08
#2319
Drove the SE-R for the first time in almost 3 weeks. Ahhhhhhhhhhh.........
2013-02-17 20:42:35
#2320
I can finally post up in this thread again. hahaha.

Re-routed my chassis harness so that its now completely tucked. Mocked up and trimmed the 93/94 front bumper for the intercooler so now its ready for paint. Got my new hood ready to go get painted and cut for the evo 8 hood vent.

Installed the 2J Racing Bump steer kit. Great looking piece and feels solid. I really dont care for the whole bump steer correction part but hopefully it will help keep the steering more solid and eliminate any movement steering wise during launches at the track.

Hooked up all my harness' and verified I can connect to the AEM after I found out that the whole AEM EMS powering off issue was due to metal shavings that had gotten into my harness connector and happened to sit between the eccs power and ground pins causing an intermittent short and causing the car to shut off. Glad it wasnt a problem internally with the board. Everything checked out great and its all ready to go for the motor to be back in.

Unmounted the intercooler to strip the overspray off of it and clean it up.

Installed the door panels and rear panels that i got out of the same 93/94 se-r. Just need to grab the carpet out of it and a couple other panels and then need to find a set of 93/94 rear seat cusions. So if anyone has a set they want to sell, please hit me up.

Installed the TDMI fender washers on the fenders and my trans side 6 speed motor mount.







Last edited by ashtonsser on 2013-02-17 at 20-46-18.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top