Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 1,801-1,810 of 4,492
2012-04-16 08:29:02
#1801
Get her running again after a very nasty gasoline leak. Turns out my gas return hose was all torn up from the end. Cut that piece off and just pulled it and clamped it back together and WALA! I can drive her again Putting on her new wheels sometime this week.
2012-04-17 03:16:21
#1802
Added some speakers to the empty holes in the rear deck over the weekend. Nice to have sound front and back again.
2012-04-17 05:29:08
#1803
Originally Posted by jamie860
Car started for the first time last night it holds idle at 1k or so and runs pig rich- checked and fixed all boost leaks, all grounds (correct), maf wiring (correct) , injector resistor box wiring (also correct), thinking maybe my maf is not metering air correctly? or ecu related.
setup is
highport de
BC2's
MSD Top feed 550cc
super 20g
log
z32 maf


injectors are at 3 bar fp ?
2012-04-17 05:50:30
#1804
Originally Posted by sr20guy
injectors are at 3 bar fp ?


Yes. Tried a different z32 maf today and still runs the same.
2012-04-17 05:54:34
#1805
whats the problem..just running rich ?
2012-04-17 06:28:28
#1806
Just bought AEM EMS... soon to be running
2012-04-17 06:42:17
#1807
Originally Posted by sr20guy
whats the problem..just running rich ?


Yes pig rich. I dont want to drive it rich. That is the only problem. edit: After rethinking the situation, a very simple notion clicked, my bov isn't recirculated yet, waiting on the IC pipe in the mail, and i still need a bung welded on it for the recirc. pipe. I have a good feeling that recirc. my bov to the intake pipe off the turbo (draw through) may solve my problem as all that air exuding from my bov would be considered a huge boost leak. Can't believe i didn't think of this earlier.
Last edited by jamie860 on 2012-04-17 at 07-09-09.
2012-04-17 19:12:38
#1808
Finally put on my Stillen FTSB
2012-04-17 21:12:54
#1809
Jamie what ecu are you running? That bov not recirculating doesn't help.
2012-04-17 21:20:32
#1810
Originally Posted by nismo94tuner
Jamie what ecu are you running? That bov not recirculating doesn't help.


jktuning basic. Yeah, was focusing on everything else but the obvious. A lot of air comes out lol, hopefully i can get it reticulated this week and figure it out.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top