Welcome to the SR20 Community Forum - The Dash.
SR20 forum logo

Thread: Running Rich Issues Code 45

+ Reply To Thread
Posts: 1-4 of 4
2016-01-24 16:40:39
Running Rich Issues Code 45
Code 45- Leaky Injector
I'm starting to do a process of elimination right now by following FSM. I'm thinking maybe o2 sensor as my bet right now or something at the ecu due to previous owners some what hack job (but they still making connections)

Things I've Done:1.) Replaced with OEM parts- O-rings, Insulators & Seals ( Gromments on intake manifold were replace months ago with OEM)
2.) After above and resetting ECU, code 45 still pops back up, So I Visually check to see if fuel injectors leaking. No Visual
3.) When first got the car replaced fuel filter with Z32 Fuel Filter 16400-Q0805 (also replace the this fuel line with OEM 8mm size,
not 5/8's like most do)
4.) cleaned orginial IACV and installed new oem gasket.

OEM Parts (from Courtesyparts) I still have but haven't installed yet. Could some of these be the issues? I doubt but here's the list
1.) fuel hose- 17555-57y10 (Above fuel tank) w/new clamps
2.) fuel hose- 17555-57y15 (above fuel tank) w/new clamps
3.) fuel filler hose - 17228-65y00 (from tank to fuel cap-bigger hose)
4.) fuel hose - 17226=50y01 (believe this is also from tank to fuel cap or somewhere around that area. Can't remember right now)
5.) Valve Cut - 17370-89910 (goes next to lower fuel tank-externally)
6.) Fuel Tank Lid seal/oring - 17342-01A00 (seal to top to remove to get fuel pump)
7.) Intake Coolant Temp Sensor (don't have part number on me but it's blue to replace the red one in there. Got it from Gspec)

Cars History: 1.) Believe its original Fuel Pump.
2.) Original Gas Cap (I will be order this to just replace it just because who knows and it's so old already)
3.) Does leak little gas when tanks filled up (Got hoses to replace this issues.)
4.) Is a sludge monster

Things I Noticed: 1.) coolant sensor temp does need to be replaced but I doubt this would be the issue.
2.) Once I reset the ECU, it will idle and run fine until the ECU starts to relearn and that's when the idle goes to shit. It really starts
to get rich.
3.) Car ran fine until recently. This was after a few things I did. Tried to install Turbo/NA timer- apexi and when I went to install
O2 tapping in and ground, notice previous owner had hacked into some of the wires. Only two I can think was the tps & rpm
signal. Didn't install turbo after all due to the relay been bad on it.
4.) Fuel Pump (not sure if it's original or not) BUT when the I first start car up (its cold here right now like 50 or so) I have to wait
for it to finishing priming in order for it to turn over/on/crank/start.
5.) did the Screw driver to fuel injectors and ALL do click the same. And I also unplugged each one individually to see if the idle got
funky/rougher and they all did.

I'll update more on this as I go. If anyone wants to chime in go for it.
2016-01-24 19:03:35

Went out to start FSM process of elimination (kinda) Not in the same order as the pages

Completed EF & EC 425 (skipped step 4 timing since I know it's correct from a few months back in doing this)
EF & EC 426 This is were it gets interesting.... started doing 5. Had to Adjust the IACV some due to higher idle. It did stall but I just gave little throttle to help it from complety dying. The engine RPMS DID drop or fall but went up to approx. 1k-1100. Here's where it gets weird, I stop there and go for a test drive since CODE 45 is no more (remind you I reset the code on the ecu and usually after it would've popped up by now).
My test drive was for about 30 miles mostly freeways. The stalling coming to a stop has also disappeared. BUT the CEL flashing on randomly without a CODE - kinda like a bad connection some where?. It would only do this when I was giving gas But at no particular time. I even tried to pull a code after wards and I got a 55. Aka everything is ok.

I'm guessing it's old wiring (I hope) or bad connections somewhere . Problem is, where? I know I was thinking ECU area due to the hack job BUT not sure now. LOL guess I'll wait to update when I discover the issue .
2016-01-25 11:57:41
Originally Posted by gEE805

3.) Car ran fine until recently. This was after a few things I did. Tried to install Turbo/NA timer- apexi and when I went to install O2 tapping in and ground, notice previous owner had hacked into some of the wires.

...is the O2 sensor "tapped" in? How was this done? From my experience, Nissans don't really like this.
2016-01-25 13:32:51
I tapped into it using a T type kinda connector. I've tapped to my previous nx year's ago and that unicorn never had an issue. You think this really would cause that? PS car is still running great. To be honest, probably the greatest since I've had it (go figure)
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)

    Back to top