Welcome to the SR20 Community Forum - The Dash.
SR20 forum logo

Thread: sr20det vtc no spark/ no start

+ Reply To Thread
Posts: 1-10 of 21
2011-11-16 15:48:16
sr20det vtc no spark/ no start
I drove the car one day. Everything ran fine. I got in the car the next day. Didnt want to start. Checked battery 12.45v. Drops to 11-10v when cranking. Battery is good. I even jumped it to make sure it wasn't the battery. Still No start. Added more gas just to be on the safe side. Even though I had 1/4 of a tank. Still no start. Popped hood. Check all my fuses in and out of car. All are good. Pulled on intercooler hoses everything is tight. no leaks after maf or where pipes connect. Fuel pump is makin noise. Walbro 255. Still I checked to make sure it was putting out fuel after fuel filter. Put hose into a bottle. Tried to start the car. Pumped out fuel. Full bottle real fast. Fuel pump is good. Took out spark plug Cyl #1. Put in coil over plug. Grounded plug to engine block. No spark. Same on cylinder # 2. So I figured its the same for 3 and 4. Pistons move up and down. Not broken timing chain. Mechanically everything is good. I have no spark. I think its CAS Sensor. I tried to google what the 4 wires were suppose to be reading with a digital voltmeter. I couldnt find anything to test my CAS sensor. I know I have power and ground. I havent checked any wires yet. That's a given but what else am I looking for? I have 4 wires coming out of my CAS sensor. Any Ideas what I should do. Any Ideas will help Im Pretty sure its electrical but anything im missing or you think I need to check will be helpful. Thanks. Im new to this forum thing so I'm still figuring out how it all works. Dunno if you email me answers to my email but here it is [email]jedieebay@yahoo.com[/email] thanks
2011-11-17 05:06:24
Check the ignitor and make sure it's getting power.
2011-11-17 06:20:19
First thing to check is make sure you have your 12V at the ignitor like he said. If your good there its more than likely a problem with the CAS which is common on the rwd det's anyways. But dont just replace parts without testing. Make sure you have a 12v power at the CAS, there should be a black wire that is the ground for that, the other two are your signal wires from your optic sensors one for fuel teeth and one for spark teeth. If your power is good there, check your main grounds on the motor, there is one on the back side of the head, make sure its still attached and then some on the intake manifold i believe.

Next i would check the connection into the ecu make sure its tight. You have your eccs relay as well make sure its putting power to the ecu.

I would double check your fusible links which are the ones for your main igntion power, Engine control fuse, and so on. They are hard to tell sometimes just looking at them that they are blown. Again check your powers and if any are missing then you know to recheck the fuses.
2011-11-17 18:41:45
Thanks guys. I got a red, white, green, and brown wire, into the ignitor. I tested the red wire. Color red i assume is my 12v power wire. Tested it at the splice where someone connected the wires. NO volts. I didn't do the swap in this car. I bought this car with sr20 already in it. Long story. My last sr20det s13 was stolen. So I came across this one. Only its not a clean wire job. I find some things that are okay like at least he soldered the wires in the ignitor where he connected them. but I want to go back through and redo the harness and clean it up. but first I need to get her running again. What next to check where my power source to the ignitor is coming from. ? and Thanks guys! I know this may be common sence but electrical is a little frustrating esp since I didn't do this swap and have double the problems trouble shooting and figuring out what someone jimmy rigged as well as the problem itself. Thanks again for the help
2011-11-17 19:27:08
not necessarily, one side you have the power wires coming from each coil, then on the other side of the ignitor you have 4 signal wires that go to the ecu one for each cylinders trigger, then one ground. One side has 5 wires, one side has 4. The wide with the 4 I believe is the powers coming from the coils. With the key on, you should have 12v on all 4 of the wires on that one side of the ignitor, then the side with the 5 has the triggers and one ground. Simple as that.

If you have no 12v at any of the 4 wires then you lost your ignition on power feed. If thats the case then you need to check your fusible links like I said. They are really hard sometimes to tell that they are blown. The one that gives you that feed is the Engine control fusibile link 25 amp fuse
2011-11-17 22:17:27
The engine cont I pulled out and its a 10amp thats near driver foot panel. Its not blown. I replaced it anyways. I didn't see any 25amp fuses. Think thats altima that uses a 25amp fuse im told. I looked under the hood and I see EGI fuse 7.5amp its not blown I replaced it. Check it I have source voltage on both sides. According to the electrical diagram that fuse is used for the following circuits,

1. The ECM relay.
2. EVAP Canister Volume Control Valve.
3. Distributor.
4. The ECM.
5. Mass Airflow Sensor.

I tried to start it again and same thing. No Fire.
I guessing its my CAS ? Which I suspected from the start. but how should I test that. Power, ground, and 5v ref in and out ?.. It Should give a on off patter with oscope but i don't own one. I'm using a digital voltmeter. I'm rusty with diag parts on the electrical side. What would you do? I got plenty of grounds. This guy that put this engine in added a lot of extra ground wires all over, on top of the stock gounds as well. I have ground wires touching fire wall, engine block, fender, battery oem ground wire, 2 more on intake manifold. and they all connect to a small metal circle about 2" around with like 6 bolts so all the wires can connect. I'm thinking that maybe this guy had a ground issue with the car before. I have driven the car now for 6 months no issue. Then one day. No start. I'm clueless. Plus I want to redo the wire harness and clean it all up but I refrain because I have a no start issue and I don't want to cause new problems. So i'm just trying to get this thing to kick and start. All I get is it turns over. I smell gas. I got no spark. Im clueless. I think my cas is bad but how do i test it. before i special order a 330 dollar cas sensor. which i dont have any extra money right now. Please help. Thanks
2011-11-17 22:46:56
If you CAS was bad your injectors wouldnt fire either. You need to check to see if your coils have 12V positive to them. If not its almost guranteed one of your main fuses are blown. The fusible links are the square looking fuses not the normal buss fuses. You have a large 75 amp fuse which is the main one and then some smaller ones, then your normal buss style fuses.

Again check your powers at your ignitor, again the 4 wire clip is your powers coming from your coil, You need to unplug it and see if you have 12v at each of the 4 wires. Dont worry about the other 5 wires on the other clip. Make sure you have your voltage.

As far as the CAS plug, you have one 12v positive, one ground and two signal wires. Make sure you have your 12v at the CAS, if you fuse that you were refering to is good then you should. Unless your main 75 amp fuse is blown. Again check them very closely.

If your injectors are firing, more than likely your CAS is still fine and its a power problem to the coils. I believe on the s13 s14 the ignition fuse in the engine bay is what supplies the 12v to the coils.

No need to actually test the CAS, you could crank it over and see if you hear the injectors firing but you can do all troubleshooting with a multimeter and checking the basics.
2011-11-18 01:24:08
He can just pull it out and spin the cas by hand too.
2011-11-18 01:36:59
yeah but its not as easy as just popping it out and back in like our distributor. If he doesnt know what he is doing he probably will have a hard time getting it back in on the right tooth. Easiest way without pulling the valve cover to ensure #1 is at TDC on the compression stroke and lining up the dots on the CAS is to mark the position of the CAS to the head and then remove the CAS cover and mark the position of the disk to one of the screws using a sharpie. Thats the easiest way to do it.

But yes you could remove it and spin it by hand with the ignition on and see if you can hear the injectors clicking. If so your CAS is still good and you more than likely dont have your 12V to the coils probably due to a bad connection or blown fuse.
2011-11-18 19:16:17
Okay I keep going in circles. I have no one to help come look at it with me. Ok so I rechecked. I have no power to ignitor. At the 4 wires in to it. Red, white, brown and green. NO power. 0v. So I wanted to double check the inj working. Took out spark plug cyl. #1 and had my brother turn the key. I saw inj spray gas into the cylinder. Awsome My cas is good. I regrounded the spark plug while in coilover plug to engine block and no spark. I have no power to the coil over plugs. What supplies power to them? I already made sure my fuses arent blown replaced them anyways. Then took dmm and have source voltage at both sides of the fuses. Show they are good. What should I do now? lol getting closer but im clueless what to check now. Thanks for all your help so far.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)

    Back to top