Welcome to the SR20 Community Forum - The Dash.
SR20 forum logo

Thread: car rpms sky rocket as soon as i plug the maf in

+ Reply To Thread
Posts: 1-10 of 21
2010-02-21 02:24:21
car rpms sky rocket as soon as i plug the maf in
So after 3 long years i finally got my car put back togeather and start it. It putters and dies, putters and dies, Finally it starts and RPMS shoot up to 5 so i kill the car. Check my throttle body and loosen cable to make sure it's not sticking open. Same thing. So i unplug my z32 maf and start it and it runs like butt but it idles around 1500 rpms and stays there. Any ideas what would cause this? bad wiring for the maf? Looked for vacuum leaks and didn't see anything, checked the actual cam timing and made sure both cams were on, more to do with it running like butt and missing. Not really sure it's been to long since i've worked on this thing. It's an enthalpy ecu tuned for Z32 and afc is set to 5 in 5 out.

2010-02-21 02:52:14
Your safc isnt wired in correctly. WHen its unplugged its running good cause its in limp mode, as soon as you plug it in its not seeing the correct voltage from the maf. Maybe you have the input/output wires flipped on the safc. Check wiring.

Even better idea, just bypass the SAFC and see how it starts.

Also, DONT QUOTE me on this, but I dont think 5 in 5 out is correct for z32 maf, again, dont quote me on that. Just doesnt ring a bell.
2010-02-21 02:56:53
check the tps
2010-02-21 02:56:54
no wiring has changed. These are the same settings and same harness and wires from when i pulled out the motor and built it.
Maybe i guess it could be a loose wire somewhere. 5 is gtir ecu and stock gtir maf, so how i ran it before was 5 and 5 since it's tuned for the maf.
2010-02-21 02:57:29
whats the best way to check it? and would TPS be linked to the maf like that?
2010-02-21 02:58:01
also just because you looked at the hoses doesnt mean you actually checked for leaks

usually when you start it up and it goes straight up to 5k its your tps.
2010-02-21 03:12:31
then unplugging the maf just puts it in limp mode and bypasses it ?
2010-02-21 03:31:02
Welp i'm an idiot. I think i figured it out. Just an FYI don't put a car together over a 3 year period because you forget shiz!!!

After this talk of TPS i thought to myself hmm i don't have a volt meter but my afc will show what it's picking up, so i go turn the key to on and press the gas peddle. Throttle stays at 0%. So then i think well shiz maybe my afc wiring got messed up when i pulled the harness out. So i get down and look at it and a lightbulb goes off. I didn't screw the ecu plug in all the way. Screw it in all the way, turn on afc, throttle 100% and reading normal.... whoops

it's to late to test tonight as it is open DP and it's late but ya that is probably why it ran like butt and rev'd up.
2010-02-21 14:15:05
Fortunately you didn't do any damage to the ECU by having the connection loose
2010-02-21 17:31:59
ok so i tested it this morning. Same issue.
it sputters to 1k then dies, if i keep trying after about 3 or 4 tries it revs to 5 k then dies revs drop... if i press the gas i can keep it running but barely and have to hold the gas open just abit or sit there and feather it.

AFC reads my throttle voltage at .3 when closed and 4.1 when WOT. so i think the TPS voltage is correct.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)

    Back to top