Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: My stock block SR20DE Updated times!

+ Reply To Thread
Posts: 171-180 of 192
2016-12-20 01:12:32
#171
double post
2016-12-20 19:16:01
#172
how the tranny broke?
2016-12-22 21:47:29
#173
Originally Posted by shady45
how the tranny broke?


It broke as I launched. Shifter is stuck between neutral and 2nd gear. Housing cracked....
2016-12-27 22:07:50
#174
Well this is new news to me. When did they release a plenum for the high port de?

I see your using the q45 tb are you still using the 3" intake piping?
2016-12-29 03:26:36
#175
Originally Posted by Haulin200sx
Well this is new news to me. When did they release a plenum for the high port de?

I see your using the q45 tb are you still using the 3" intake piping?


The Plenum was a something that Greg @GSpec Performance and I had discussed for a while now. I asked if he could reach out to Xcessive and see if they could assist me with my Manifold needs. Rich @Xcessive was more than accommodating. And Yes I am using a Q45 TB and MAF.
Last edited by TRUSE-R on 2016-12-29 at 03-30-05.
2016-12-29 15:01:19
#176
is it the standard plenum with just a new plate for the de runners/bolt pattern? or is the plate welded to the runners?
2016-12-29 20:44:53
#177
3" piping the whole way? Looks like 3" going ito 2.5"
2016-12-29 22:26:44
#178
Originally Posted by Haulin200sx
is it the standard plenum with just a new plate for the de runners/bolt pattern? or is the plate welded to the runners?



Plate is welded to the runners.
2016-12-29 22:40:09
#179
Originally Posted by Haulin200sx
3" piping the whole way? Looks like 3" going ito 2.5"


I used leftover piping. Inlet is 4in reduced to 3in @ the MAF.
2016-12-29 22:53:16
#180
+ Reply To Thread
Quick Reply
Thread Information
There are currently ? users browsing this thread. (? members & ? guests)
StubUserName

Back to top