Welcome to the SR20 Community Forum - The Dash.
SR20 forum logo

Thread: No Fuel and no tach after changing Calum chips

+ Reply To Thread
Posts: 1-10 of 14
2010-06-23 19:36:58
No Fuel and no tach after changing Calum chips
So I have decided to burn new Calum (basic) roms with different bins for N60 maf. Took off DE maf, connected N60, unhooked my ECU took out the chips, replaced with new ones (N60 program), hooked it back up and I get to fuel pump.
- fuse ok
- pump makes noise when hooked straight to the battery
- tried different relays (no difference)
- when I remove the relay and connect the two (closely oriented connectors) I get the pump to make noise upon ignition on
- I turn the car and car barely studders and dies right away, there is also no Tach during that short few moments.

So I disonnected the battery, changed the chips back to the original ones (that I know were working a day before), changed the MAF and still the same symptoms.

Can it be crapped out fuel pump (which doesn't explain why the relay doesn't energize properly).

Any suggestions?

2010-06-23 20:45:41
Check the ignition fuse in the engine bay.
2010-06-23 23:36:40
Hope you wired the maf correctly, could have killed the ecu.
2010-06-23 23:50:48
maybe bad chips??
2010-06-24 00:20:11
i have seen several people have the fuel pump part in the ecu go bad with calum boards. most likely static killed the circuit when you replaced the chips. hard wire that fuel pump and your good to go.
2010-06-24 00:41:51
this happened to my jwt ecu and my calum ecu.

thats why ill never agian run either of those ****s.

2010-06-24 02:57:42
I mean this happens with bins that came from Calum and bins that I burnt myself. This is the update:

- no power from ECU to the fuel pump relay
- no tach signal (doesn't show rpm)
- when shorted relay sockets, the pump works and car starts (harder start but idles ok)
- Consult connection shows the Rpm and no ECU codes come up
- the fans are not coming on (even after reaching 221F)

Let me know if you have any other ideas.

2010-06-24 07:10:14
try another ecu. Could be the board isn't installed right into the ecu or bad rom image or no rom image at all.
2010-06-25 19:44:03
Is there an easy way to try DE ecu without switching my Calum daughterboard?
2010-06-25 21:32:01
Yes plug it in and unplug the maf.
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)

    Back to top