Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 3,721-3,730 of 4,492
2015-05-05 11:59:40
#3721
Originally Posted by Mr
Originally Posted by 1fastser
Took advantage of a $9.95 oil/filter change special at the dealership...might as well let them experience the pleasure of changing the filter on an NX with ABS. It was amusing watching the young bucks try to figure out how to get the oil filter out...as they shined their flashlights from underneath the car...


I hope they didn't put cheap oil in your engine.


I'm sure they did...it'll be fine for a month because I plan on changing the oil again right before the convention drive...
2015-05-05 13:37:29
#3722
This past weekend, my Dad and I undertook the project of:

* Replacing Inner and Outer Tie Rod Ends/End Links/Boots
* Replacing LCAs
* Replacing Water Pump
* Replacing Front Rotors
* Replacing Front Wheel Bearings
* Replacing Front Sway Bar Bushings
* Installing JGY Underdrive Pulleys
* Reinforcing the Motor Mounts - http://www.sr20-forum.com/general-sr20/19092-filled-my-motor-mounts-polyurethane-awesome.html
* Installing 3-point Progress LCA Brace
* Installing Octotat RSTB with triangulator
* Installing B14 seatbelts in the B Pillar
* Turning the gutted cat into a test pipe

Here's a few pics - https://plus.google.com/photos/109547535739901455455/albums/6145372274915856689

The front motor mount was completely useless, allowing the engine to twist as you torqued the engine and causing the shifter to move around some. After weighing our options (and striking out trying to find a new one available same-day,) we decided to weld the steel sleeve to a piece of steel plate, then fix that part inside the void with some JB Weld, in order to spread the load throughout the circumference and adding a couple of screws to keep it all in place.

The other 3 mounts were reinforced with some PL adhesive to fill the existing voids, since they seemed to be in decent shape already.

The main hurdle we faced (and continue to face) is that one of the two captive nuts inside the front chassis rail that receive the front-to-rear crossmember is (and previously was) stripped. We considered fixing a bolt in place to turn it into a lug, but we decided to cut a hole in the top (near the condenser) so that we can weld a second nut to the first and get a nice, strong, stealth fix while using the OEM bolts.

Overall, we're more than half-way though this project, and I'm really looking forward to driving her again.
2015-05-05 19:33:13
#3723
Kicked it for not cooperating
2015-05-07 00:43:18
#3724
fixed a slight exhaust leak where the slip fit for the tri-y goes and fixed a hood rattle. 100000000x better now.
2015-05-07 01:03:25
#3725
Apologized for kicking her.
2015-05-07 01:09:00
#3726
BEWM!
2015-05-07 01:09:51
#3727
What Did You Do To Your B13 Today?
2015-05-07 11:39:48
#3728
Passed emissions for the last time! With flying colors too. She was like a quarter of the limit on everything. Now to new door hinges and eventually on to address the rust.
2015-05-09 12:36:09
#3729


SCRUBBED OUT MY FLOOR MATS.
2015-05-12 21:43:05
#3730
Just got these puppies in the mail! 8 bucks!
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top