Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 731-740 of 4,492
2011-08-24 03:24:20
#731
Installed a VE! And installed my 4 month old jdm de on the homies car thats going for sale!
2011-08-24 03:46:24
#732
Originally Posted by ny5speed
where'd you get the nissan badges for the K1 center caps?


How did you see that?!! Got em off ebay. Took a few tries to get the right ones but it was very worth it. PM me as a reminder and I'll see if I can find the details and seller... It's been about 3 years now since I got them.

Last edited by CleanSER on 2011-08-27 at 01-56-21.
2011-08-25 17:03:17
#733
Got her a present, Stillen ftsb and two idle control valves

2011-08-25 20:57:24
#734
Bought A JDM Sr20de Today From Sr20 Member Falcon021084 . Took The Old Motor Out & Swapped Out Some Parts That Were Missing On The JDM Motor .

Mounted The Transmission & Axles . Pushed The Motor Under The Car So I Can Finish The Install .

Started Raining So That Is All I Did Today . Hopefully Tomorrow I Can Have It Completed & Running .
Last edited by SunnyB13NJ on 2011-08-25 at 21-01-10.
2011-08-25 21:20:26
#735
Did a compression test

152 149 150 155


Just realized i forgot to open the throttle while i cranked...
Last edited by unijabnx2000 on 2011-08-25 at 21-52-10.
2011-08-26 03:29:09
#736
Originally Posted by SE-RMonkey
Can I get an Amen?



Drove it to work and put 12 more miles on the clock.

Amen to stock B13's!
2011-08-26 04:02:13
#737
Originally Posted by Redline
Originally Posted by cortrim1
Put the motor and tranny back in the car. Spent 2hrs getting the cross member to bolt up right:o I had to unbolt the cross member to get the rear mount to bolt up and had to use a pry bar on the front mount.





man I got one of that mount and I couldn't freaken get the crossmember to bolt up, so I sold it.

Anyways I did a tune up on my baby gave her a nice shower and took her for a nice drive to the bank.


thats weird because mine bolted up fine!
2011-08-26 04:03:41
#738
pulled and rolled my fenders, wheels spacers, 16x8 with 205/55s, and intercooler and piping and nx ecu, and cleaned and regrounded my maf. then, hit one of those parking spot cement things while pulling in to a parking spot(forgetting how low my car is) and ripped off my bumper, bent my intercooler, and scratched my new rims. all in one day.


awesome.
2011-08-26 21:02:11
#739
drove it to work with the new VE and man!!!! vvl isnt hooked up but still pulls great! its on DE ecu and DE maf but for not itll have to do and DAMN I LOVE THE TONE THE VE HAS!! it sounds too sexxyyy
2011-08-27 00:36:07
#740
Finally Started My B13 After A Year Of Sitting . Bought A New Starter . Today Was A Good Day . Will Post Pictures Of My B13 Of Today .
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top