Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Thread: What Did You Do To Your B13 Today?

+ Reply To Thread
Posts: 1,261-1,270 of 4,489
2011-12-24 16:08:57
#1261
Installed a new passenger headlight & corner housing, nice to have all the proper lights finally. Then I stopped by the body shop I used to work at for an estimate. They are going to primer/paint/clear the hood & fender. Plus make any needed pulls on the frame to get everything lined up perfect. All for $500 Car should be looking real nice in 2 weeks.
2011-12-24 16:33:14
#1262
Started to disassemble the front end for engine removal.
2011-12-24 17:53:27
#1263
No more cold, hard steering wheel.

Before...




After...

2011-12-24 18:43:10
#1264
Nice change. The stock B13 wheel even the SE-R one is one of the worst I've seen - its so flexible it used to shake at idle in my 2nd B13 with the S3/4 cams. Now I have BNR32 wheels for both, currently a RNN14 GTi-R wheel in the 2nd car, big improvement, too.
2011-12-24 21:52:41
#1265
i have a NX pulsar coupe steering wheel looks just like the s13 but no c/c
Last edited by inspiredB13 on 2011-12-24 at 21-53-20. Reason: .
2011-12-24 22:07:29
#1266
Originally Posted by inspiredB13
i have a NX pulsar coupe steering wheel looks just like the s13 but no c/c


I found a really clean NX Pulsar wheel at the u-pull-it, but no CC buttons. The plan was for the S13 wheel to go into the SE-R, then the SE-R wheel into the XE, but sadly the eBay S13 bit is kinda rough. Hardly worthy of the SE-R.
2011-12-24 23:55:42
#1267
wired up all the new switches and the water /meth monitor gauge. tested pump and gauge. Then performed a leak down test on the new motor. Now its ready for the dyno.
2011-12-25 01:09:59
#1268
Cant wait to see the numbers man. Good job.
2011-12-25 18:30:06
#1269
Originally Posted by ashtonsser
Cant wait to see the numbers man. Good job.


Thank you sir. I did the test cold as well so I am pleased with the results. Not bad for my first motor assembly.
2011-12-26 07:10:47
#1270
Originally Posted by cortrim1
Thank you sir. I did the test cold as well so I am pleased with the results. Not bad for my first motor assembly.


Not bad at all!
+ Reply To Thread
  • [Type to search users.]
  • Quick Reply
    Thread Information
    There are currently ? users browsing this thread. (? members & ? guests)
    StubUserName

    Back to top