Welcome to the SR20 Community Forum - The Dash.
Register
SR20 forum logo

Forum: General SR20

Main Forum Discussion

+ Post New Thread
Forum: General SR20
- Main Forum Discussion
Threads: 5,567-5,588 of 7,017
Title / Thread Starter
Last Post By
Car died after start up
Started by jagy, 2009-03-31 21:09
Replies: 6
Views: 1,467
2009-03-31 21:09
how to bore maf?
Started by MY95SER, 2009-03-31 20:55
Replies: 5
Views: 1,776
2009-03-31 20:55
Nissan Performance Tuning
Started by xCONWRATHx, 2009-03-31 05:24
Replies: 2
Views: 1,675
2009-03-31 05:24
ECU Question
Started by blairellis, 2009-03-30 21:47
Replies: 5
Views: 1,691
2009-03-30 21:47
Oil filter housing.!
Started by SE-R2FAST, 2009-03-30 06:23 1 2
Replies: 13
Views: 4,455
2009-03-30 06:23
dude guys this is sick
Started by PEDRONX2k, 2009-03-29 00:45 1 2
Replies: 15
Views: 2,815
2009-03-29 00:45
oil pressure ??
Started by mayko, 2009-03-28 22:08
Replies: 0
Views: 876
2009-03-28 22:08
sr20 help
Started by 92 Black13, 2009-03-28 22:06
Replies: 1
Views: 952
2009-03-28 22:06
Replies: 0
Views: 889
2009-03-28 21:17
Anyone had this bolt fail?
Started by Kishada, 2009-03-28 19:08
Replies: 3
Views: 1,300
2009-03-28 19:08
a bit concerned,,
Started by Tearoffguy, 2009-03-28 08:55 1 2
Replies: 11
Views: 2,681
2009-03-28 08:55
Broken rocker arm
Started by gnugfur, 2009-03-27 23:40
Replies: 2
Views: 1,681
2009-03-27 23:40
Having fuel issues...HELP
Started by eggman, 2009-03-27 21:46
Replies: 0
Views: 767
2009-03-27 21:46
Cold Start Issues?
Started by AaroNX, 2009-03-27 15:47
Replies: 0
Views: 774
2009-03-27 15:47
Window Tint Removal options?
Started by AztecSR20, 2009-03-26 22:59 1 2
Replies: 12
Views: 3,870
2009-03-26 22:59
g20 automatic to manual
Started by crznx2000, 2009-03-26 20:01
Replies: 2
Views: 1,555
2009-03-26 20:01
Replies: 13
Views: 3,212
2009-03-26 05:12
No hazards or blinkers...HELP
Started by Jon Doe, 2009-03-25 19:56 1 2
Replies: 11
Views: 2,472
2009-03-25 19:56
Replies: 2
Views: 999
2009-03-25 16:01
Metric to SAE Conversion
Started by canx2k, 2009-03-25 12:45
Replies: 2
Views: 4,593
2009-03-25 12:45
cam noise??
Started by sentraserdet, 2009-03-25 04:30
Replies: 4
Views: 1,172
2009-03-25 04:30
Only 1 wiper works (Passenger)
Started by Amazing Asian, 2009-03-25 04:03
Replies: 5
Views: 1,277
2009-03-25 04:03
Icon Legend and Forum Information
Contains unread posts
Contains no unread posts
Thread is closed
You have posted in this thread
Users Browsing this Forum
There are currently ? users browsing this forum. (? members & ? guests)
StubUserName

Back to top